:::: MENU ::::

OSX on the eee 901

Image1 I have iAtkos 10.5.5 up and running (for two weeks now) on my eee PC 901.

This is a condensed version of the thread here (posted mainly by cybermaus) and I have modified

some points after several atemmpts to get the thing up and running.

I’ll keep posting articles as I find out new things.

0 Get some useful Tools:

OSX86 Tool: pcwizcomputer.com

Pacifist :   www.versiontracker.com

1. BIOS Update to fix ACPI Problems

Get modified Bios from: osrom.net

The simplest way to do a BIOS Update – use Asus Windows Tool and Run update from file

BIOS Update is always a risk – for me, all went fine and the long boot time was fixed!

2. Install

2.1. System Boot – Enter BIOS Settings with F2

Go to Advanced Onboard Device Configuration

  • Onboard LAN: Disable
  • Onboard Camera: Enable
  • Onboard Wlan: Enable
  • Onboard Bluetooth: Enable
  • Advanced – CPU settings
  • Max CPUID Value Limit: Disable
  • Hyper hreading: Disable
  • Intel Speedsep Enable

Hard Disk Drives:

  • 1st Drive: HDD:SS-ASUS-PHISON SSD

Save & Exit

2.2. Boot with iatkos v4i

Utilities->Disk Utility:

8GB SSD: Partition-> 1 Partition (

  • Name:OSX¬†¬†¬†¬† (Or any name you like)
  • Format: Mac OS Extended¬†¬† (I did not use Journaled, which is a bit faster but not as secure)
  • Options: MBR (GUID suggested by cybermaus, but with the MBR option you can use a tool like Acronis TrueImage to backup the partition)

4GB SSD: Partition -> Leave it or format it to Mac OS Extended (journaled) for use as data disk (OSX does not fit on this one)

Disk Utility->Quit Disk Utility

Welcome->Continue

Welcome->Agree

2.3 Installtion on the OSX Partition

Install Sumary->Customize

x IATKOS v4i Main System

x Darwin Bootloader

* Do not install from section Stock (replace kernel later)

x Additional Patches:

xxSMBIOS driver

xxxx AppleSMBIOS-27 6th rev. MacBook

xxxx Remove Termal kexts

x Drivers

xx Intel

xxxx GMA950

xxxx System

x SATA

Done

Install

NB: If Install Window doesnt show up:

Window->Installer Log

Window -> Zoom

Window-> Bring all to Front

Installer Log-> Show Errors and Progress

2.4 Install kexts

Download from paulswinddriverutilitypack here

  • AboutThisMac
  • AppleIntelGMA950.kext
  • AppleIntegratedFramebuffer.kext
  • ClamshellDisplay.kext
  • Natit.kext

2.5 Run OSYX86Tool

Enable/Disable Quarz GL

2.6 Install Stock Kernel

Boot with iatkos v4i

Welcome->Continue

Welcome->Agree

Installtion on OSX Partition

Install Sumary->Customize

x Stock Files

xx Kernel 9.4.0

2.7 Install WLAN Driver if you stayed with the original Ralink card

Download here

Use specifik application to control WLAN

I for my part installed a Apple Airport mini PCI WLAN card – BroadCom BCM 94321MC 802.11n (search for BCM94321MC on eBay – around 20$-30$)

which works out of the box and is recognised as Airport card.

3. Battery Meter Fix

3.1 Delete Powermanagement bundle from /System/Library/SystemConfiguration/PowerManagement.bundle

3.2 Get Combo Mac OSX Combo Update 10.5.4 from Apple – Support – Downloads http://www.apple.com/support/downloads/

3.3 Get pacifist from versiontracker: www.versiontracker.com—12743 http://www.versiontracker.com/dyn/moreinfo/macosx/12743

We need to install original PowerManagement.bundle

3.4 Open downloaded Combo Update in Pacifist and Extract PowerManagement.bundle

3.4 Copy extracted PowerManagement.bundle to /System/Library/SystemConfiguration/PowerManagement.bundle

Repair Permissions and Reset Extesion Cache with OSX86Tool

3.5 Install ACPIBattery.kext from: www.superhai.com

4. Update to 10.5.5 (thanks to iSkylla – http://forum.insanelymac.com/index.php?showtopic=107340)

4.1 Backup your partition (just in case)

4.2 Open Terminal and type

  • sudo -s
  • *type your password*
  • while sleep 1; do rm -rf /System/Library/Extensions/AppleIntelCPUPowerManagement.kext; done

4.3 Open 10.5.3 Update Installer

4.4 Run update BUT DO NOT RESTART

4.5 Go back to your terminal and press Control C to end the script

4.6 In terminal type (I didn’t have to do this, but just to be sure):

  • nano /System/InstallAtStartup/scripts/1
  • Replace the line Dont Steal Mac OS X.kext with dsmos.kext¬†¬†¬†¬† (If this line does not exist then go directly to step 4.7)

4.7 Restart and boot with -v

Update: In order to work properly after the update reinstall all kexts as described in 2.4 and 3

What works:

System running with EFI, vanilla and Quarz extreme support

Stock Kernel : working with EFI

GMA950 : working with QE & GL

Sleep Mode : working (With Shutdown Window by pressing power button)

Wlan : working (After Start and wake on Powersaving a manual switch off/on is needed on original Ralink Card)

Camera: : working

Multitouch : 2 finger scrolling, 3 finger control, 2 finger doubletab

SD Slot

What does not work yet:

Sound

Ethernet

Speedstep

Brightness control

Some useful sites:

http://ipis-osx.wikidot.com/

http://www.maceee.com/

http://eeepc-osx.wikispaces.com/901

http://wiki.taruga.net/


15 Comments

  • Ryan |

    I am SO not technical. I bought a Windows XP eeePC for my wife, but she can’t stand the small keyboard. It’s been sitting useless since I bought it for 4 months. Any chance I can send it to you and have you help me get Mac on there? I’ve got the license covered – I bought the 5-pack of Leopard and only used 3 (so far) for my macs. If you want money, a 6 pack, misc electronics, one of my cds, eternal life, whatever…it’ll be worth it to me. I just hate having it sit there and do nothing, and it would really help me out a lot.

  • power goh |

    i installed osx on my 901 with ideneb 10.5.5 and i have a blank signal for my webcam. its recognized by the system profiler but i just get a black image in photobooth. any ideas on how to fix this?

    • Gregory Cohen |

      It’s because you have the linux version of the 901. The linux and the XP versions came with different cameras. The Xp version is os x compatible, the linux version is not.

  • admin |

    @power goh: Have you tried the correct kexts?

    (Especially the AppleIntelGMA950.kext)

    If you mean “black” by saying “blank” the problem is probably related to your graphics kexts.

  • power goh |

    Thanks admin. I did my installation following maceee.com. I used ideneb 10.5.5. I installed a set of kext that maceee had compiled. I just tried installing the appleintelgma950 kext from your site. I still get nothing. The green light on my cam comes on sometimes but no image. When I try macam, it says no camera. It’s not a huge deal but it is very frustrating. I am downloading the iatkos distro and I may try reinstalling everything. Any other thoughts would be hugely appreciated. Thanks!

  • power goh |

    yea i have, no luck, sometimes i get a green light but always no image.

  • gopowergoh |

    Admin, i was wondering if you had any suggestions for me? are there any drivers on ur 901 that you could possible upload for me? Any help would be greatly appreciated. thanks

  • admin |

    @gopowergoh

    Welcome here gopowergoh (saw you on ipis-osx)…

    Sorry can’t really help you with that I don’t have the 901 anymore (got the 1000H).

    But basically you should be able to use the kexts and bundles from my 1000H installation tutorial.

    BTW. I just posted a reply to your plist question on ipis-osx.

    Nik (nhirt on ipis-osx)

  • power goh |

    Thanks nik. You rock. I thought that was you on ipis. Got the dock issue working but no luck with the camera, i had most of the kext from maceee. I wanted to try an install with iAtkos but my install disc will never word. My eee keeps telling me to insert a proper boot disc. Any suggestions? Thanks

  • floor jack |

    I have to say, that I could not agree with you in 100%, but it’s just my IMHO, which indeed could be very wrong.

    p.s. You have an awesome template for your blog. Where did you find it?